Logo (język programowania)

Z Wikipedii, wolnej encyklopedii
Skocz do: nawigacji, wyszukiwania
Ujednoznacznienie Ten artykuł dotyczy języka programowania. Zobacz też: inne znaczenia Logo.

Logo – (gr. λόγος [logos] – słowo, myśl) – język programowania stworzony jako środek do nauczania informatyki i matematyki. Składa się z gotowych elementarnych procedur, które służą do definiowania procedur użytkownika. Został zaprojektowany przez pracującego pod koniec lat 60. na MIT Seymoura Paperta, który inspirował się pracami francuskiego psychologa i pedagoga Jeana Piageta[1].

Logo oparte jest na LISP z zupełnie inną składnią i używa tzw. „grafiki żółwia” (ang. turtle graphics).

Programowanie żółwia[edytuj | edytuj kod]

LogoRecursiveSpiral.jpg

Za pomocą następujących komend:

 ;komendy angielskie
 FORWARD 100
 LEFT 90
 FORWARD 100
 LEFT 90
 FORWARD 100
 LEFT 90
 FORWARD 100
 
 ;komendy polskie
 naprzód 100
 lewo 90
 naprzód 100
 lewo 90
 naprzód 100
 lewo 90
 naprzód 100

można sprawić, że żółw narysuje kwadrat o boku 100.

Komendy:

 ;komendy angielskie
 FORWARD 100
 RIGHT 120
 FORWARD 100
 RIGHT 120
 FORWARD 100
 
 ;komendy polskie
 naprzód 100
 prawo 120
 naprzód 100
 prawo 120
 naprzód 100

narysują trójkąt równoboczny.

W Logo używać można pętli. Powyższy kwadrat narysować można również tak:

;angielskie
REPEAT 4 [FORWARD 100 LEFT 90]
;polskie
powtórz 4 [naprzód 100 lewo 90]

Komendy żółwia można grupować i tworzyć własne procedury np.:

 ;angielskie
 TO KWADRAT
   REPEAT 4 [FORWARD 100 LEFT 90]
 END
 
 ;polskie
 oto kwadrat
   powtórz 4 [naprzód 100 lewo 90]
 już

teraz, po napisaniu KWADRAT, żółw „będzie wiedział”, co narysować.

Istnieje również implementacja języka Logo o nazwie Imagine (polska wersja znana jako „Logomocja, polska edycja Imagine”), w której można realizować obiektowy model programowania w oparciu o klasy i obiekty.

Zobacz też[edytuj | edytuj kod]

Przypisy

Linki zewnętrzne[edytuj | edytuj kod]