Skrót: WP:VEI

Pomoc:VisualEditor/Instrukcja

Z Wikipedii, wolnej encyklopedii
Skocz do: nawigacja, szukaj
Dla każdego
Te informacje dotyczą edytora wizualnego. Zobacz analogiczne dotyczące wikikodu (Czym to się różni?)

Jeżeli chcesz wypróbować edytor wizualny, nie zmieniając artykułu, tu możesz swobodnie go testować. Nie jest konieczne posiadanie konta, aby zmienić tę stronę za pomocą edytora wizualnego.

Uruchamianie edytora wizualnego

Aby zmienić stronę za pomocą edytora wizualnego, należy kliknąć w zakładkę „Edytuj” u góry strony.

Może potrwać kilka sekund, zanim otworzy się strona edycji, lub dłużej, jeżeli strona jest bardzo długa.

Kliknięcie w zakładkę „Edytuj kod źródłowy” otworzy klasyczny edytor kodu źródłowego.

VisualEditor edit tab-pl.png

Aby uruchomić edytor wizualny, należy kliknąć w link „edytuj” znajdujący się przy nagłówku każdej sekcji.
VisualEditor - edytuj sekcję.png

Na początek: pasek narzędzi edytora wizualnego

Zrzut ekranu: pasek narzędzi edytora wizualnego
Po uruchomieniu edytora wizualnego na górze ekranu pojawi się pasek narzędzi. Zawiera on znajome ikony:

VisualEditor - Toolbar - Undo-redo.png
Cofnij lub Ponów wykonane zmiany.

VisualEditor Toolbar Headings-pl.png
Nagłówki (menu rozwijane): pozwala zmienić formatowanie tekstu. Aby zmienić styl akapitu, należy umieścić kursor w tekście (nie ma potrzeby zaznaczania czegokolwiek). Tytuły sekcji są formatowane jako „Podstawowy nagłówek rozdziału”, a podsekcji jako „Podstawowy nagłówek rozdziału”, „Nagłówek podrozdziału 1 stopnia” itd. Zwykłe formatowanie tekstu to „Akapit”.

VisualEditor Toolbar Formatting-pl.png

Formatowanie: Kliknięcie na „A” otwiera menu.

  • „Pogrubienie” (B) wytłuszcza zaznaczony tekst.
  • „Kursywa” (I) pochyla zaznaczony tekst.
  • „Indeks górny” (xI) umieszcza zaznaczony tekst w indeksie górnym.
  • „Indeks dolny” (xI) umieszcza zaznaczony tekst w indeksie dolnym.
  • „Przekreślenie” (A) (przekreślone A, tak jak przekreślone M) przekreślenie tekstu.
  • Element „Kod programu” (para nawiasów klamrowych: {}) ustawia czcionkę zaznaczonego tekstu na czcionkę o stałej szerokości; nie wpływa to na pozostały tekst w akapicie.
  • Element „Podkreślenie” (A) dodaje linię ciągłą pod zaznaczonym tekstem.
  • „Język” (Aあ) pozwala ustawić język zaznaczonego tekstu (np. na japoński) i kierunek pisania (np. od prawej do lewej).
  • Ostatni element („VisualEditor MediaWiki theme clear icon bitmap.png”), zwany „Wyczyść styl”, usuwa formatowanie zaznaczonego tekstu, w tym linkowanie.

Jeżeli nie zaznaczono żadnego tekstu, kliknięcie na „A” otworzy menu, a wybrane formatowanie będzie się odnosiło do tekstu, który będzie wpisany w miejscu, w którym znajduje się kursor.


VisualEditor - Toolbar - Linking.png
Linkowanie: ikona łańcucha symbolizuje narzędzie wstawiania odnośników (linków). Kliknięcie w nią (zazwyczaj po zaznaczeniu tekstu) otwiera okno linku.
VisualEditor citoid Cite button.png
„Przypis”: przycisku „Przypis” używamy do dodania przypisów. Oprogramowanie spróbuje samodzielnie wypełnić szablon podawania źródła.

VisualEditor Toolbar Lists and indentation-pl.png
Listy i wcięcia: pierwsze dwa elementy pozwalają formatować tekst jako „Lista wypunktowana” albo „Lista numerowana”. Kolejne dwa służą do powiększania lub zmniejszania wcięcia listy elementów.

VisualEditor Insert Menu-pl.png
Wstaw: menu „Wstaw” może się różnić na różnych wiki. Poniżej zamieszczamy listę wszystkich możliwych opcji.
  • Ikona „Multimedia” (obrazek przedstawiający góry) otwiera okno multimediów.
  • Ikona „Szablon” (puzel) otwiera okno zmieniania szablonów.
  • „Komentarz” (dymek) otwiera okno dodawania komentarzy, które są niewidoczne dla czytelników; są widoczne tylko w trybie edycji jako wykrzyknik w kółku.
  • Ikona „Tabela” wstawia tabelę.
  • Ikona „⧼visualeditor-mwgalleryinspector-title⧽” (zbiór zdjęć) otwiera okno wstawiania galerii.
  • Ikona „Wzór” (Σ) otwiera okno wstawiania wzorów matematycznych.
  • Ikona „Hieroglify” (symbol anch – ☥) otwiera okno wstawiania hieroglifów (patrz niżej).
  • Ikona „Lista przypisów” (trzy książki) otwiera okno, w którym możesz określić, gdzie przypisy zostaną wyświetlone czytelnikowi. Zazwyczaj na stronie trzeba użyć tego tylko raz.

Wstawianie znaków specjalnych: kliknięcie na ikonę „Znak specjalny” (Ω) w menu „Wstaw” otwiera okno z wieloma znakami specjalnymi. Klikając na znak, umieszczasz go w tekście. Zbiór znaków specjalnych zawiera niektóre standardowe symbole, litery diakrytyzowane i symbole matematyczne. (Tę listę można lokalnie dostosowywać).
VisualEditor Toolbar SpecialCharacters-pl.png

VisualEditor More Settings-pl.png
Menu „Opcje strony” znajduje się na lewo od przycisku „Zapisz”. W tym menu znajdują się opcje strony, takie jak ustalenie strony jako przekierowanie czy ustalenie sortowania strony w kategorii. Można też dodać, zmieniać czy usunąć kategorie oraz zobaczyć element „Język”, listę artykułów na ten sam temat napisanych w innych językach. Możesz także przełączyć się z edytora wizualnego na klasyczny edytor kodu źródłowego i odwrotnie bez utraty zmian, które wprowadziłeś.

Zapisywanie zmian

Po zakończeniu edycji kliknij na niebieski przycisk „Zapisz” na pasku narzędzi. Nie da się kliknąć, jeśli nie dokonano żadnych zmian (przycisk jest szary). Aby anulować wszystkie zmiany edycyjne, wystarczy zamknąć okno przeglądarki.
VisualEditor toolbar actions-pl.png

Naciśnięcie zielonego przycisku „Zapisz” otwiera okno, w którym można wprowadzić krótkie podsumowanie swoich działań, oznaczyć edycję jako drobną czy zdecydować się na obserwowanie przyszłych zmian na stronie. To okno odpowiada polu opisu zmian w edytorze kodu źródłowego.

Możesz też przejrzeć swoje zmiany, używając przycisku „Skontroluj swoje zmiany”. W ten sposób upewnisz się jeszcze przed zapisaniem edycji, że zmiany są zgodne z twoimi intencjami. Ta opcja odpowiada przyciskowi „Podgląd zmian” w edytorze kodu źródłowego.

Klikając na przycisk „Kontynuuj edycję”, wracasz do edytowanej strony. Później możesz zapisać wszystkie swoje zmiany.

VisualEditor save dialog-pl.png

Edycja linków

VisualEditor - Toolbar - Linking.png
Możesz dodać link za pomocą ikony „Link” w pasku narzędzi lub używając skrótu klawiszowego Ctrl+K (lub ⌘ Command+K na Mac-u).

Jeżeli zaznaczyłeś (podświetliłeś) tekst, naciśnięcie na „Link” spowoduje użycie tego tekstu do tworzenia linku. W przypadku linku obejmującego jeden wyraz możesz albo zaznaczyć wyraz, albo umieścić kursor w środku tego wyrazu.


VisualEditor-link tool-search results.png
Niezależnie od tego, czy użyjesz ikonki czy skrótu, otworzy się okno dialogowe, w którym możesz wpisać adres linku.

VisualEditor wyszuka proponowane linki wewnętrzne pasujące do tego, co wpiszesz.


VisualEditor link tool 2015.png
Gdy wpiszesz lub wybierzesz link, możesz wcisnąć ↵ Enter albo kliknąć „Gotowe”. Twój link pojawi się na zmienianej stronie, ale, jak pozostałe zmiany, nie będzie zapisany, dopóki nie zapiszesz strony.

VisualEditor-link tool-external link.png
Aby dodać link spoza Wikipedii, proces jest podobny: wybierz zakładkę „Link zewnętrzny” i wpisz URL.

VisualEditor link tool simple link.png
Linki zewnętrzne bez etykiet wyglądają tak: [1]. Możesz je dodać, klikając gdziekolwiek indziej (np. po spacji). Otwórz narzędzie do edycji linków, klikając na przycisk lub używając skrótu klawiszowego. Wpisz URL i kliknij przycisk „Gotowe”, by wstawić link.

VisualEditor-context menu-link tool.png
Aby zmienić lub usunąć istniejący link, kliknij na niego, a następnie na ikonę „Link” widoczną obok. Pojawi się okno do zmieniania linku. (Możesz też kliknąć na taką samą ikonę na pasku narzędzi lub użyć skrótu klawiszowego Ctrl+K). Jeżeli link zostanie zaznaczony, to wyświetli się na niebieskim tle.

W oknie zmieniania linku możesz zmienić stronę, do której ma być link, albo usunąć link, klikając na ikonę „Usuń”, znajdującą się w rogu okna. Możesz także otworzyć link w osobnym oknie, klikając przycisk „⧼visualeditor-linkinspector-open⧽”. (Możesz sprawdzić, czy link zewnętrzny jest poprawny).

Jeżeli chcesz wyjść z okna edycji linku (tekstu wyświetlonego jako link) lub kontynuować pisanie po tym linku, możesz nacisnąć :

  • pojedyncze naciśnięcie spowoduje wyjście z okna edycji linku i umieści kursor na końcu linku,
  • dwukrotne naciśnięcie umieści kursor za linkiem, w miejscu, gdzie możesz kontynuować pisanie.

Edycja przypisów


Edycja istniejącego przypisu

Aby zmienić istniejący przypis, kliknij na niego (zazwyczaj to liczba w nawiasie). Zobaczysz ikonę „Zwykły przypis” (obrazek zakładki w książce) albo ikonę i nazwę szablonu, który użyto do utworzenia przypisu. W obu przypadkach kliknięcie na „Edytuj” otworzy okno, w którym możesz zmienić przypis.
VisualEditor - ikona przypisu.png

Jeżeli obok ikony „Zwykły przypis” widnieje „Zwykły wygląd”, kliknięcie na „Edytuj” otwiera okno dialogowe. By zmienić tekst przypisu, kliknij na niego.

Czasami użyto szablonu formatującego przypis do właściwego standardu. Jeżeli w przypisie użyto szablonu, przesunięcie kursora na tekście spowoduje podświetlenie się tekstu.

Jeżeli użyto szablonu i klikniesz na tekst formatowany za pomocą szablonu, pojawi się ikona „Szablon”. Kliknij przycisk „Edytuj”, by edytować zawartość szablonu.

VisualEditor - treść przypisu.png

Jeżeli pojawia się wtedy standardowa ikona przypisu, kliknięcie „Edytuj” otworzy okno edytowania szablonu.
VisualEditor - Editing References - Cite Web.png

Kliknięcie na ikonę Dołączony szablon pozwala dodać i usuwać rodzaje informacji oraz zmieniać wpisane informacje. Na początku pojawią się tylko te pola (parametry), które zawierają treść. By dodać pola, kliknij na „Dodaj więcej informacji” na dole okna dialogowego.
VisualEditor - edycja szablonu w przypisie.png

Kiedy skończysz, kliknij Zastosuj.
VisualEditor Apply Changes-pl.png

Używanie istniejącego przypisu

Jeżeli strona zawiera już przypisy, możesz wybrać jeden z nich, o ile dotyczy on informacji, do której chcesz go dodać.

Aby użyć istniejącego przypisu, należy umieścić kursor w miejscu, w którym ma być dodany i kliknąć na zakładkę „Użyj istniejącego” w menu „Przypis”).

VisualEditor references more.png

W oknie „Przypis” zobaczysz listę istniejących przypisów, które możesz wybrać i wstawić ponownie. Jeżeli jest ich wiele, możesz użyć wyszukiwarki (podpowiadającej „Wyszukiwanie spośród użytych przypisów”) i otrzymać listę tylko tych przypisów, które zawierają tekst, który wpiszesz do wyszukiwarki.
VisualEditor - wyszukiwarka przypisów.png

Tworzenie nowego przypisu

Aby utworzyć nowy przypis, umieść kursor w miejscu, w którym chcesz go dodać. Następnie wybierz odpowiedni typ przypisu z menu „Przypis”.
VisualEditor - wstaw przypis.png

Używając „zwykłego wyglądu”

W tym oknie dialogowym możesz dodać, edytować i formatować swój przypis.

Możesz określić przynależność przypisu do danej grupy (zwykle do żadnej nie należy). Ta opcja jest używana do wyświetlania grup przypisów za pomocą narzędzia „Lista przypisów”.

VisualEditor - treść przypisu.png

Jeżeli dodajesz nowy przypis i chcesz w nim zawrzeć szablon przypisu albo jakiś inny, kliknij na ikonę „Szablon” (obrazek puzzla) w menu „Wstaw” w pasku narzędziowym okna tworzenia nowego przypisu.
VisualEditor Template Insert Menu-pl.png

Wybierz szablon, który chcesz użyć, dodaj i zmieniaj tak samo, jak zmieniasz istniejący. (Spójrz na sekcję Edycja szablonów, jeżeli chcesz dowiedzieć się więcej o szablonach).

Kiedy skończysz edytować nowy szablon, kliknij na „Zastosuj”, by wrócić do edytora przypisów i znów „Zastosuj”, by wrócić do edytowanej strony.

VisualEditor - wybierz szablon w przypisie.png

Jeżeli strona nie zawiera jeszcze listy przypisów (np. tworzysz właśnie pierwszy przypis), trzeba ją dodać, aby treść przypisów wyświetlała się na stronie.

Umieść kursor w miejscu, w którym ma wyświetlać się lista przypisów (zwykle na dole strony) i otwórz menu „Wstaw” i kliknij na ikonę „Lista przypisów” (obrazek trzech książek).

VisualEditor References List Insert Menu-pl.png

Gdy używasz kilku grup przypisów, co jest rzadkie, to możesz wybrać jedną z nich w tym oknie. Tylko te przypisy, które należą do niej, wyświetlą się w miejscu, w którym umieszczasz daną grupę.

Ostatnim krokiem w oknie edycji grup przypisów jest kliknięcie na „Wstaw”.

VisualEditor references list-pl.png

Używając standardowych szablonów cytowań

W menu „Przypis” jest do wyboru „Podaj źródło” i „Zwykły wygląd”. (Na obrazku obok widnieje przykład z innej wiki).
VisualEditor - Editing References - Cite Pulldown.png

Kliknięcie na „Podaj źródło” zaprowadzi Cię do edytora szablonu „Cytuj”. Ważne pola informacji mogą być oznaczone gwiazdką. Domyślnie wyświetlają się najczęściej używane pola, ale być może nie musisz wypełniać wszystkich.
VisualEditor - Editing references - Cite book required fields.png

By dodać więcej parametrów, przewiń okno edycji szablonu i kliknij na „Dodaj więcej informacji”.

Kiedy skończysz, kliknij na „Wstaw”.

VisualEditor - Editing references - Add parameter.png

Edycja obrazków i innych plików multimedialnych

Edycja plików

Aby dodać nowe zdjęcie (lub inny plik multimedialny) do strony, kliknij ikonę „Multimedia” (obrazek gór) w rozwijanym menu „Wstaw”. Zdjęcie zostanie wstawione w miejscu, gdzie znajduje się kursor.
VisualEditor Media Insert Menu-pl.png

Kliknięcie na ikonę „Multimedia” otwiera okno dialogowe, które automatycznie wyszukuje w Wikimedia Commons i w waszej wiki pliki multimedialne związane z tytułem edytowanej strony.

Możesz szukać innych plików multimedialnych, zmieniając tekst w oknie dialogowym w polu wyszukiwania.

Kliknij na miniaturę, aby wybrać plik.

To umieszcza plik na stronie, którą edytujesz.

VisualEditor - Media editing 2.png

Kiedy wybierzesz i wstawisz plik na stronę, pojawi się nowe okno dialogowe, w którym możesz dodać (lub zmienić) opis, który może zawierać sformatowany tekst i linki.
VisualEditor - Media editing 6.png

Okno edycji multimediów pozwala na dodawanie alternatywnych opisów używanych przez osoby, które używają czytników ekranowych oraz przez tych, którzy wyłączyli wyświetlanie plików.
Media editing 7.png

Możesz także skorzystać z różnych ustawień plików w oknie „Zaawansowane”. Znajdziesz tam opcje wyrównania, rodzaju wyświetlania i rozmiaru pliku.
VisualEditor - Media editing 8.png

Kiedy skończysz, kliknij Zastosuj by zamknąć okno i wrócić do edycji strony.
VisualEditor Apply Changes-pl.png

Można zmieniać opis lub ustawienia istniejącej grafiki poprzez kliknięcie tej grafiki, a następnie kliknięcia ikony „Multimedia” umieszczonej poniżej grafiki.

Możesz zmienić rozmiar istniejącego pliku, klikając na niego i przesuwając ikony zmieniania rozmiaru (dwukierunkowe strzałki na jednym albo dwóch dolnych rogach pliku).

Możesz także przeciągać i upuszczać plik, by umieścić go wyżej albo niżej.

VisualEditor - Media editing 3.png

Przesyłanie plików

Możesz przesyłac nowe pliki multimedialne, używając zakładki w menu edycji plików.
VisualEditor Media Insert Menu-en short.png

Należy kliknąć przycisk „Prześlij” i wybrać plik na komputerze lokalnym - można wpisać nazwę lub zaczepić i przeciągnąć do okna.
VisualEditor - Media upload 1.PNG

Należy opisać plik i umieścić go w kategorii, co pozwoli innym go odnaleźć.
VisualEditor - Media upload 2.PNG

Po zakończeniu plik zostanie wstawiony na stronę.
VisualEditor-logo.svg

Edycja i wstawianie galerii zdjęć


Aby edytować w edytorze wizualnym istniejącą galerię należy ją kliknąć. Następnie na dole galerii należy kliknąć ikonę galerii (zestaw grafik). Spowoduje to wywołanie edytora galerii z pełnym wykazem grafik w galerii.
VisualEditor - Gallery2.png
Edytor galerii obecnie to zwykłe okno w którym można edytować istniejące galerie w wikikodzie. Aby do galerii dodać nową grafikę, to należy wpisać nazwę pliku, następnie kreskę (|) i opis tej grafiki, przy czym każda grafiki musi być wpisana w oddzielnym wierszu. Można również edytować daną listę - usuwając lub przemieszczając grafiki lub zmieniając ich opisy.

Kliknięcie przycisku „Gotowe” powoduje wyjście z edytora galerii i zostaną pokazane wprowadzane zmiany tak jak są one widoczne dla czytelników.

Pamiętaj, że wyjście z okna edycji galerii nie zapisze zmian. Tak jak w przypadku innych zmian dokonanych za pomocą edytora wizualnego, trzeba zapisać całą stronę, aby zmiany zostały zachowane.

VisualEditor - Gallery3.png

Edycja szablonów

Pierwsze kroki

Aby dodać nowy szablon, umieść kursor w miejscu, w którym chcesz go dodać i kliknij na ikonę „Szablon” (obrazek puzzla) umieszczoną w menu „Wstaw”.
VisualEditor Template Insert Menu-pl.png

Wpisz nazwę szablonu, który chcesz dodać. Kiedy zobaczysz go na liście, kliknij na jego nazwie. Następnie kliknij „Dodaj szablon”.
VisualEditor - wyszukiwarka szablonów.png

Można także edytować szablony, które znajdują się na stronie, poprzez kliknięcie na nie (zaznaczą się na niebiesko) i kliknięcie na ikonę „Szablon”. Następnie należy kliknąć „Edytuj”.
VisualEditor - zaznaczony szablon.png

Niektóre szablony są niewidoczne w trybie edycji za pomocą edytora wizualnego. Takie szablony są oznaczone ikoną puzzla.
VisualEditor template not visible.png

Kliknięcie na ikonę spowoduje wyświetlenie ikony puzzla. Takie szablony można edytować [przyp. tłumacza: spróbujcie kliknąć dwa razy na ikonę puzzla].
VisualEditor template not visible context menu.png

Parametry szablonu

Jeśli dodaje się lub otwiera istniejący szablon, to edytor wizualny otwiera okno dialogowe „Dołączony szablon”. Zawartość tego okna zależy od tego, czy istnieją parametry TemplateData dla danego szablonu.

Szablon na obrazku obok nie ma TemplateData. Widać tylko link do dokumentacji szablonu. Można spojrzeć na dokumentację, by sprawdzić, czy szablon ma parametry (pola) i co w nich umieszczać. Parametry nienazwane powinny zostać określone w edytorze wizualnym jako kolejne numery: nazwa pierwszego to 1, nazwa drugiego to 2 itd.
VisualEditor template with no TemplateData.png

Jeżeli szablon ma TemplateData, w oknie ukaże się lista odpowiednio nazwanych sugerowanych pól.
VisualEditor template with TemplateData.png

Można edytować parametry wyświetlające się w oknie edycji szablonu. Można także dodawać parametry, klikając na „Dodaj więcej informacji” na samym dole okna.
VisualEditor - TemplateData są 2.png

Jeżeli szablon zawiera inne szablony, pojawią się one jako parametry. Mogą być edytowane i usuwane poprzez kliknięcie na nazwę podszablonu.

Nowe podszablony są dodawane analogicznie, jak nowe parametry. Możesz sprawdzić dokumentację szablonu by upewnić się, czy szablon zawiera podszablony.

VisualEditor - Template editing 5.png

Zakończenie

Po zakończeniu należy kliknąć „Zastosuj” by zamknąć okno i wrócić do edycji strony.
VisualEditor Apply Changes-pl.png

Wklejanie szablonów

Kiedy trzeba wkleić szablon, wpisz subst: (łącznie z dwukropkiem) przed nazwą szablonu.

Autouzupełnianie nie działa z kodem subst:. Jeżeli potrzebne jest autouzupełnianie, to należy wyszukać szablon i następnie dodać subst: na początku nazwy szablonu.

Następnie należy kliknąć na zielony przycisk „Dodaj szablon”.

Należy dodać parametry i kliknąć „Wstaw”.

VisualEditor - tworzenie subst2.png

Po kliknięciu „Zastosuj” będzie widoczne rozwinięcie szablonu.
VisualEditor - dołączony subst.png

Edytowanie list

VisualEditor Toolbar Lists and indentation-pl.png
Można użyć edytora wizualnego do tworzenia list i do zmiany formatowania istniejących list. Są dwa rodzaje list: nienumerowane (punktowe) i numerowane.

Aby utworzyć listę, należy kliknąć na jednym z dwóch dostępnych elementów w menu. Jeżeli wcześniej istniała lista (w osobnych liniach), należy ją zaznaczyć, a następnie kliknąć na wybranym elemencie menu.


VisualEditor lists 1 unordered bullet.png
VisualEditor lists 2 ordered numbered.png
Przykłady dwóch rodzajów list: nienumerowana i numerowana.

VisualEditor lists 3 select to indent.png
By zmienić wcięcie części elementów listy, należy zaznaczyć tę część…

VisualEditor lists 4 indentation menu.png
…następnie użyć menu albo nacisnąć Tab ↹. (Tab ↹ zwiększa wcięcie, ⇧ Shift+Tab ↹ zmniejsza wcięcie).

VisualEditor lists after indenting.png
Przykład zwiększonego wcięcia.

VisualEditor lists mixed.png
Można także mieszać numerowane i punktowane elementy listy, jeżeli lista ma różne wcięcia.

Edycja tabel

VisualEditor insert table.png
Edytor wizualny może być używany do wstawiania i edytowania tabel.

Można również zastosować metodę „przeciągnij i upuść”, mając na komputerze tabelę zapisaną w pliku w formacie .csv.


Po kliknięciu przycisku „Tabela” w menu „Wstaw” edytor wizualny wstawi pustą tabelę 4x4.

W trybie edycji tabeli jest dostępne menu edycji tabeli. Z tego menu można dodać nagłówek tabeli.

VisualEditor empty table.png

By wybrać komórkę, należy kliknąć na nią raz.
VisualEditor tables select one cell.png

By edytować zawartość komórki (np. dopisać coś albo poprawić błąd w pisowni), należy kliknąć dwa razy. Można też zaznaczyć komórkę i nacisnąć ↵ Enter.

Aby zakończyć edycję komórki, należy kliknąć gdziekolwiek indziej.

VisualEditor tables type inside a cell.png

VisualEditor table editing add and remove columns.png
Można dodawać i usuwać kolumny i wiersze.

Można także łączyć komórki: należy je zaznaczyć i kliknąć „Nagłówek”
VisualEditor tables merge cells.png

W wyniku łączenia komórek zawartość tylko z jednej z nich jest zachowana. Aby odzyskać zawartość utraconą w wyniku łączenia, należy użyć przycisku Cofnij, przesunąć albo skopiować zawartość, a następnie połączyć komórki ponownie.
VisualEditor tables post-merge cell.png

Można też rozdzielić uprzednio połączone komórki. Zawartość połączonych komórek pozostanie w pierwszej spośród rozdzielonych. W razie potrzeby można wyciąć ją i wkleić do innych komórek.
VisualEditor tables split cells.png

Edycja kategorii

VisualEditor category item-pl.png
Edytowanie kategorii wykonuje się po kliknięciu pozycji „Kategorie” w menu „Opcje strony”.

VisualEditor category editing-pl.png
Przycisk „Kategorie” otwiera okno, w którym wymienione są kategorie oraz pozwala dodać nowe.

Istnieje możliwość skonfigurowania klucza sortowania, używanego do wstawiania danej strony na stronach kategorii.

Na przykład domyślnym kluczem sortowania hasła „Gabriel Narutowicz” jest tytuł hasła i w kategorii „Prezydenci Polski” to hasło byłoby wykazane pod literą „G”, a nie „N” (faktycznie to hasło ma jawnie ustawiony klucz sortowania „Narutowicz, Gabriel” i jest wykazane pod literą „N”).


VisualEditor - dodawanie kategorii 2.png
Aby dodać nową kategorię, należy wpisać jej nazwę w pole „Dodaj kategorię”. Po wpisaniu nazwy kategorii edytor wizualny odszuka możliwe dopasowania istniejących kategorii. Można zarówno wybrać istniejącą kategorię, albo dodać nową. (Dopóki strona kategorii nie zostanie utworzona, nowa kategoria będzie pokazana jako czerwony link po zachowaniu zmian).

VisualEditor - usuwanie kategorii.png
Aby usunąć dołączoną kategorię, należy kliknąć na nią, a następnie na ikonę „Usuń” (obrazek kosza) w oknie, które się pojawi.

Można także określić klucz sortowania dla poszczególnych kategorii. Zastępuje on w danym przypadku ogólny klucz sortowania.


VisualEditor Apply Changes-pl.png
Po zakończeniu należy kliknąć Zastosuj, by zamknąć okno i wrócić do edycji strony.

Edycja ustawień strony

VisualEditor page settings item-pl.png
Aby wejść do edycji ustawień strony, należy kliknąć przycisk „Opcje strony” na belce narzędziowej i wybrać pozycję „Ustawienia strony”.

VisualEditor Page Settings-pl.png
Kliknięcie przycisku „Ustawienia strony” otwiera okno dialogowe pokazujące kilka opcji.

VisualEditor Page Settings Redirects-pl.png
Można zdefiniować przekierowanie do innej strony za pomocą zaznaczenia pola wyboru „Przekieruj tę stronę do”, a następnie wpisania nazwy strony do której ma być przeniesiony czytelnik, który wejdzie na stronę która jest edytowana.

Na dole jest opcja chroniąca przed aktualizacją danego przekierowania w przypadku przeniesienia strony będącej aktualnie celem przekierowania (standardowo takie przeniesienie powoduje powstanie na tej stronie kolejnego przekierowania). Używane jest bardzo rzadko.


VisualEditor Page Settings TOC-pl.png
Poprzez kliknięcie jednego z tych trzech przycisków można wskazać, czy na stronie jest wstawiany spis treści. Domyślnym wyborem jest „W razie potrzeby”, czyli wstawianie spisu treści w przypadku gdy hasło ma trzy sekcje lub więcej.

VisualEditor Page Settings Edit Links-pl.png
Zaznaczenie tego pola wyboru powoduje, że obok tytułu sekcji nie będzie pokazywany przycisk „Edytuj”.

VisualEditor Apply Changes-pl.png
Po zakończeniu edytowania menu „Opcje strony” należy kliknąć przycisk „Zastosuj” aby powrócić do edycji strony.

Edycja formuł matematycznych

Ta sekcja zawiera dokumentację starszej wersji edytora wizualnego.

Aby dodać nowy wzór matematyczny należy ustawić wskaźnik kursora w miejscu zamierzonego wstawienia i kliknąć ikonę „Wzór” („Σ”) w przycisk „Wstaw” paska narzędziowego.
VisualEditor Formula Insert Menu-pl.png

Zostanie otwarte okno do wpisania wzoru z użyciem składni LaTeX-u. Edytor wizualny uaktualni wzór i pokaże wygląd wzoru po zakończeniu zmian. Gdy jesteśmy uszczęśliwieni zmianami, to należy je zatwierdzić klikając przycisk „Gotowe”.
VisualEditor formula-pl.png

Aby edytować wzory matematyczne na stronie, należy kliknąć występującą tu ikonę „Σ”. Spowoduje to otwarcie okna wzorów, w którym można wprowadzić zmiany.
VisualEditor - editing existing mathematical formula.png

Wzory matematyczne mogą być osadzone w linii (wraz z tekstem) albo osobno.
VisualEditor mathematic formula inline.png

Edycja fragmentów liryki i innych specjalnych elementów

Niektóre elementy, jak np. galerie plików i zapisy nutowe nie są jeszcze obsługiwane przez edytor wizualny. Aby je dodać lub edytować, należy edytować kod źródłowy.
VisualEditor editing poem 1.png

W większości przypadków istniejące elementy mogą być wstawiane, ale wstawienie niektórych nowych elementów może nie być obsługiwane przez edytor wizualny.
VisualEditor editing poem 2.png

Edytor wizualny nie umożliwia automatycznego wstawiania na stronie oznaczenia daty.

Dopóki nie będzie to w pełni obsługiwane, można to skopiować z innej strony albo przejść do edycji kodu źródłowego.

Skróty klawiszowe

Wielu użytkowników jest przyzwyczajonych do wpisywania wikikodu wprost, w szczególności wytłuszczenia, pochylenia i linków. Skróty klawiszowe pozwalają szybko zastosować podobne formatowanie bez konieczności klikania w pasek narzędzi. VisualEditor zna popularne ogólne skróty oraz skróty stosowane przez niektórych użytkowników.

Skrót PC Akcja Skrót Maca

Ctrl+B Pogrubienie ⌘ Cmd+B

Ctrl+I Kursywa ⌘ Cmd+I

Ctrl+K Wstaw link ⌘ Cmd+K

Ctrl+X Wytnij ⌘ Cmd+X

Ctrl+C Kopiuj ⌘ Cmd+C

Ctrl+V Wklej ⌘ Cmd+V

Ctrl+Z Cofnij ⌘ Cmd+Z